Kismet Wireless

Kismet Forums

 

Posted by:karhakol
Subject:kismet + OpenWRT + nanostation5
Date:02:58:10 26/07/2009

Configuration:
root@OpenWrt:/# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

br-lan no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11a ESSID:"" Nickname:""
Mode:Monitor Frequency:5.18 GHz Access Point: 00:15:6D:D0:77:21
Bit Rate:0 kb/s Tx-Power:17 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/70 Signal level=-96 dBm Noise level=-96 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ifconfig:
wifi0 Link encap:UNSPEC HWaddr 00-15-6D-D0-77-21-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:195
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:5 Memory:b8500000-b85ffffc

/etc/kismet/kismet_drone.conf

source=ath5k,ath0,wireless

root@OpenWrt:/# kismet_drone -f /etc/kismet/kismet_drone.conf
Using alternate config file: /etc/kismet/kismet_drone.conf
Suid priv-dropping disabled. This may not be secure.
No specific sources given to be enabled, all will be enabled.
Enabling channel hopping.
Disabling channel splitting.
Source 0 (wireless): Enabling monitor mode for ath5k source interface ath0 channel 6...
FATAL: Failed to set channel 6 22:Invalid argument
root@OpenWrt:/#

What is the problem?

THX.


Reply to this message