Kismet Wireless

Kismet Forums

 

Posted by:thulldud
Subject:Startup segfault on Sabayon 4: update
Date:04:26:11 13/07/2009

> > > Glad it's not just me, anyway. Sabayon is very pretty, and most things seem to "just work" out of the box with it, but when it breaks, it be real ugly.
> > >
> > > That being said, I will just try this again with the latest build of Sabayon, and then I'm going after them if it's still b0rken.
> > >
> > > Will let you know how it turns out.
> >
> > I'm open to ideas they have, but since this code is stable (or at least, doesn't exhibit this brand of wackiness) on all other linux distros that I know of, as well as (i'm told) compiling and working fine in icc, and bsd, and osx, and cygwin ... I'm going to have to blame Sabayon for this one :)
> >
> > -m
>
> Already opened a ticket at Sabayon for it. Meanwhile, I have installed version 4.1 so I can try the build again...I just know I'm gonna get asked about it. There is a version 4.2 out, but it isn't on the mirrors yet.

Tried the 4.2, same issue. Pretty sure it's just a crocked library build, as you suggested. Meanwhile, I just loaded SUSE 11.1 on here, since I was already accustomed to using SUSE on my main desktop system, and, what do you know, kismet configured and built right up. Only had to run back to the disk for libpcap (which I hadn't needed to do in Sabayon!), and it is now running suid with my Realtek 8187 dongle and makeshift cantenna, picking up signals all around.

This Sabayon thing is irksome. So pretty a system, and not that many bugs either, but the ones it has are strategically placed. :-P

Thanks for responding, btw. I'll come back and post another update when and if I have one.


Reply to this message