Kismet Wireless

Kismet Forums

 

Posted by:MrOrange
Subject:double wireless card
Date:16:46:57 02/07/2009

> > I've finally upgrade to Kismet-2009-06-R1 but set-up seems to be different:
> > I've two 802.11p (5.89GHz) interfaces (ath0 and ath1) each one have other three interfaces athX.1 .2 .3... I usually use them to communicate with other identical machine using protocols encapsulated in IPv6.
> >
> > I starts kismet using "kismet -X -c ath0" but it replace all interfaces ath0 ath0.0 ath0.1 ath0.2, with kis0 kis0.0 kis0.1 kis0.2 and channel hop is still enable!
> >
> > The new kis0 is a monitor mode interface and I like it (I can capture Radiotap) but I would like to keep ath0 ath0.0 ath0.1 ath0.2 and also have kis0 in monitor mode with channel hop not-enable at same frequency of ath0 (5.89GHz)!
> >
>
> It's in in the docs, in short, disable vap destruction and disable channel hopping on that interface when you define it.
>
> However, don't expect madwifi to work when you run kismet. Madwifi doesn't do a very good job of multi-vap in different modes.
>
> > When I close Kismet, kis0 has been destroyed and there is no ath0 interface
> >
>
> Correct. This is expected for how you configured it.
>
> >
> > /tmp is flushed automatically at set intervals by Fedora
>
> I don't know what this means. Kismet doesn't do anything with /tmp; if you're logging there and you don't want files to go away, don't log there. This is also a terrible thing for fedora to be doing, but whatever.
>
> >
> > It also seems Kismet is not using my /usr/local/etc/kismet.conf because I've add
> > sourceopts=ath0:novapkill
> > and I've change log-files default name but It still save with the old one even if I run kismet using -f option
> > kismet -c ath0 -X -f /usr/local/etc/kismet.conf
>
> You're either not running the kismet you think you are or you're not editing the config file you think you are.
>
> -m


In order to keep save my ath0 and ath1 I've create two monitor interfaces using
wlanconfig mon0 create wlandev wifi0 wlanmode monitor
wlanconfig mon1 create wlandev wifi1 wlanmode monitor
when I start Kismet in mon0 (kismet -c mon0 -X) it freeze all system!


Reply to this message