Kismet Wireless

Kismet Forums

 

Posted by:MrOrange
Subject:double wireless card
Date:16:43:36 01/07/2009

> > I've a pc with 2 identical wireless card and I can't understand how should I configure kismet.conf in "source="
> > I've tried:
> > source=atheros,ath0,atheros
> > it doesn't work
>
> Step 1: Get the new Kismet releases (2009-05-RC2 or 2009-06-R1) which are based on newcore.
>
> Step 2: kismet -c ath0
>
> or to use both
>
> kismet -c ath0 -c ath1
>
> Step 3: Consider going to ath5k, it's a lot better and will work a lot better for you with Kismet. Trust me.
>
> -m

I've finally upgrade to Kismet-2009-06-R1 but set-up seems to be different:
I've two 802.11p (5.89GHz) interfaces (ath0 and ath1) each one have other three interfaces athX.1 .2 .3... I usually use them to communicate with other identical machine using protocols encapsulated in IPv6.

I starts kismet using "kismet -X -c ath0" but it replace all interfaces ath0 ath0.0 ath0.1 ath0.2, with kis0 kis0.0 kis0.1 kis0.2 and channel hop is still enable!

The new kis0 is a monitor mode interface and I like it (I can capture Radiotap) but I would like to keep ath0 ath0.0 ath0.1 ath0.2 and also have kis0 in monitor mode with channel hop not-enable at same frequency of ath0 (5.89GHz)!

When I close Kismet, kis0 has been destroyed and there is no ath0 interface


/tmp is flushed automatically at set intervals by Fedora

It also seems Kismet is not using my /usr/local/etc/kismet.conf because I've add
sourceopts=ath0:novapkill
and I've change log-files default name but It still save with the old one even if I run kismet using -f option
kismet -c ath0 -X -f /usr/local/etc/kismet.conf


Do you have any suggestion?


Reply to this message