Kismet Wireless

Kismet Forums

 

Posted by:shaleny
Subject:kismet, iwl3945, wierdness
Date:06:26:36 05/06/2009

> tcpdump -s 0 -i wlan0 -w foo.cap while Kismet is running.

I tried this both with monitoring on wlan0 and with vap. In both cases there was nothing captured.

> Also try telling Kismet to create a rfmon vap instead of changing the mode of the main interface:
>
> ncsource=wlan0:vap=wlan0mon

I made several attempts and it worked in some cases. I tried to figure out what was the difference between the attempts and it was the state of the wlan0 interface. If wlan0 is not associated with access point then scan gives no results (same keeps for monitoring interface created with aircmon-ng). But if wlan0 is still connected then kismet can see both my access point and my laptop.

Currently my network is WPA PSK AES-CCM encrypted but previously I tried to use kismet with this network and disabled encryption. There were no results either.

Do I expect too much and this is just sane behavior?


Reply to this message