Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:kismet, iwl3945, wierdness
Date:01:44:34 05/06/2009

> Recently I've been trying to get kismet worked with my wireless card. At first I tried 2008_05_R1-4 version, but after some unsuccessful attempts I switched to current svn trunk. The problem was that kismet did not manage to detect an Access Point (which I own) with broadcasted ESSID. The access point is Dlink DIR-320 wifi-router running under DD-WRT v24-sp2. Kismet was starting just sanely but it has not been receiving any packets. After several hours without any success I gave a try to aircrack. I created a monitoring interface mon0 issuing "sudo airmon-ng start wlan0" command. Aircrack managed to find my access point. After that I decided to specify mon0 as a source in /etc/kismet.conf. I was surprised but this got it worked. My kernel is 2.6.29-ARCH.
> lspci | grep Wire
> 10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
> Could somebody possible explain me what was my error?

tcpdump -s 0 -i wlan0 -w foo.cap while Kismet is running.

Also try telling Kismet to create a rfmon vap instead of changing the mode of the main interface:

ncsource=wlan0:vap=wlan0mon


Reply to this message