Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:RC2 Segmentation Fault (at launch)
Date:04:58:13 28/05/2009

> I have attempted to install RC2 on my Gentoo/Sabayon box. I tried to follow the steps closely - first a unzipping, then ./configure, then make, then make suidinstall (followed by adding the user to the kismet group). This installs kismet newcore into my /usr/local/bin with the config files in /usr/local/etc.
>
> Whenever I try to run kismet, I get:
>
> ERROR: Reading config file '%h/.kismet/kismet_ui.conf': 2 (No such file or directory)
> Segmentation fault
>
> My understanding is that %h is the home directory, so it should be <homedirectory>/.kismet/ , right?
>
> The install didn't create the /.kismet directory - so I've even made one and dropped the config files in, but I still receive the same error.
>
> I get the feeling I'm missing something obvious - Anyone have any input?
>
> Thanks!

My bet is something wacky with your passwd file permissions (should be readable by all) - this looks like it can't call getpwent() on your user.

/etc/passwd should be a+r, /etc/shadow definitely should not be. Check that, and I'll put in some handlers for getpwent() failing.

[edit] I've committed changes to svn trunk that should, at least, prevent a segv here, and will throw up alerts about how things are wonky.

-m


Reply to this message