Kismet Wireless

Kismet Forums

 

Posted by:CagaRegras
Subject:Acer Aspire One
Date:12:02:45 05/04/2009

> If I run lspci -v, this is what I get, hope it supplies the correct info.
>
> Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
> Subsystem: Foxconn International, Inc. Device e008
> Flags: bus master, fast devsel, latency 0, IRQ 18
> Memory at 55200000 (64-bit, non-prefetchable) [size=64K]
> Capabilities: <access denied>
> Kernel driver in use: ath5k_pci
> Kernel modules: ath_pci, ath5k

I'm using the madwifi-hal-0.10.5.6-r3861-20080903 version driver. It seems it was specifically built both for AA1 and some models of Asus EeePC with the same chipset. With this driver, you're able to set your device to RF mode. Once you've the driver working normally, you will use wifi0 as your source in Kismet's configuration file: source=madwifi_g,wifi0,whatever

You'll have to disable (blacklist) or uninstall ath5k. Besides the fact you're using both ath_pci and ath5k at the same time, which is incorrect I suppose, you're probably not using the ath_pci version I mentioned above. In the directory "scripts" of the madwifi source code, you have 2 important bash scripts to use. The first to unload all madwifi modules in current memory and the other to uninstall the said unwanted drivers.

Best of luck!


Reply to this message