Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:I started over
Date:20:16:58 23/03/2009

> I installed fresh SLED 11 RC1, newest ncurses, flex, bison, GMP, tack, libpcap, GMP-Math, ImageMagick, and expat.
>
> When I run ./configure on kismet, I get no errors. When I run make I get:
>
> In file included from kismet_client.cc:32:
> timetracker.h:49: warning: ‘typedef’ was ignored in this declaration
> g++ -o kismet_client util.o configfile.o speech.o manuf.o tcpclient.o timetracker.o frontend.o cursesfront.o panelfront.o panelfront_display.o panelfront_input.o gpsd.o getopt.o kismet_client.o -lstdc++ -lm -lz -lpanel -lncurses
> /usr/lib/gcc/i586-suse-linux/4.3/../../../libncurses.a(lib_mouse.o): In function `load_gpm_library':
> lib_mouse.c:(.text+0x701): undefined reference to `dlopen'
> lib_mouse.c:(.text+0x72b): undefined reference to `dlsym'
> lib_mouse.c:(.text+0x755): undefined reference to `dlsym'
> lib_mouse.c:(.text+0x77b): undefined reference to `dlsym'
> lib_mouse.c:(.text+0x7a1): undefined reference to `dlsym'
> lib_mouse.c:(.text+0x7f2): undefined reference to `dlclose'
> /usr/lib/gcc/i586-suse-linux/4.3/../../../libncurses.a(lib_mouse.o): In function `enable_gpm_mouse':
> lib_mouse.c:(.text+0x856): undefined reference to `dlclose'
> collect2: ld returned 1 exit status
> make: *** [kismet_client] Error 1
>
>
> Any ideas? I never had this much difficulty with kismet before. I ran it on SLED 10.0, 10.1, and 10.2 without problems on the same machine I am using now.

No clue, I don't use SLES and this doesn't happen on any other distro I *do* use. Presumably sles11 broke something or you didn't install some developer component they decided to customize.

If libncurses needs libdl it needs to pull it in via the linker like any other distribution.

-m


Reply to this message