Kismet Wireless

Kismet Forums

 

Posted by:greg123
Subject:TCP error on EEEPC
Date:10:45:09 01/02/2009

> > This seems to have been discussed several times in the past (although on different platforms than the EEEPC), but I didn't see what if anything was the resolution.
> >
> > I run kismet, the panel comes up and displays several wireless entities along with information about how many packets it has captured. Then after a second or 2 it dies with the following message:
> >
> > localhost:2501 TCP error: socket returned EOF, server has closed the connection.
> >
> > I am running just the standard EEEPc system(xandros), although I did have to rebuild the 2.6.21.4 kernal in order to get madwifi to build (along with installing all the development stuff (c++ etc)).
> >
> > Is there anything else I am missing?
> >
> > Thanks
>
> run kismet_server on it's own, but it's probably either networkmanager or dhcp killing the interface, you need to disable them.



OK, I tried running kismet_server in a seperate window and got some messages about some networks that it found then got a message:

FATAL: Failed to set channel 52 22:Invalid argument
Terminating
Didn't detect any Cisco Discovery Packets, unlinking cisco dump
Didn't see any weak encryption packets, unlinking weak file
Sending termination request to channel control child 15345...
Waiting for channel control child 15345 to exit...
Kismet exiting.

This was all so quick, that I didn't have time to get the client up and running in the other window.


Reply to this message