Kismet Wireless

Kismet Forums

 

Posted by:mattias
Subject:Problems getting Kismet to start with Intel 3945ABG
Date:21:33:16 11/01/2009

> > > I am using Kismet 2008 05 R1. I tried installing using a package manager and using by compiling from source but I am getting the same error.
> > >
> > > My kernel version is 2.6.24-21-generic.
> > >
> > > I am using iwl3945 as my capture source type.
> > >
> > > I have tried all the other similar ones: ipw3945, ipwlivetap. But they do not work.
> > >
> > > The error I get when attempting "sudo kismet" is:
> > >
> > > FATAL: channel get ioctl failed 95:Operation not supported
> > > Done.
> > >
> > > I have read that this means that I need to change my drivers. But I have up-to-date iwlwifi drivers (which contain the file iwl3945) in the kernel directory.
> >
> > Should work fine with iwl, I use it with the 4965 variants. You definitely can't use it with the ipw or ipwlivetap modes for an iwl driver, those are for the ipw intel driver which is out-of-tree
> >
> > -m
>
> Hello,
>
> Yes the iwl3945 is definitely the right device but it still fails to function.

PROBLEM: Fatal error enabling monitor mode, 'monitor' ioctl not available
Some capture sources use a private ioctl, 'monitor', to enable rfmon.
If Kismet is unable to find this ioctl, it means that the wrong
interface was specified, the wrong capture type is being used, or
most commonly, the drivers you are using have not been patched or the
patched drivers are not being loaded.
Be sure to download any patches needed for the drivers you are using,
and make sure that no other copies of those drivers exist in your
/lib/modules/kern-version/ directory. You may need to restart pcmcia-cs
if your wireless card was already running when you installed the patched
drivers.
FIX: Provide the correct interface and ensure that the patched drivers are
loaded.

I have the most recent drivers... is there some modified driver source I should be using? Do I have to use legacy drivers?

Please help.


Reply to this message