Kismet Wireless

Kismet Forums

 

Posted by:uberathome3
Subject:GPS returns 0
Date:09:38:00 27/12/2008

> > > > I am using a Magellan "Color" GPS with Kismet.
> > > > gpsd detects and appears to work fine on the USB connection ...
> > > > However when I start Kismet GPS = true on standard port it is not detected and Kismet does not show anything. When I turn on the lock in the .conf file i.e =true Kismet detects the GPS but it all returns 0
> > > > Why does this happen when this feature is meant to stop this?
> > > > Anyway How can I get Kismet to use the GPS
> > > > some more info
> > > > Ubuntu 8.04
> > > > USB GPS connection - Through serial adapter
> > > > recent HP Laptop
> > > > GPS has coverage
> > > > gpsd reports that everything is fine
> > > >
> > > > Thank you in advance
> > >
> > > + Everything is running w/ sudo ie ubuntu root
> >
> > Try a different version of gpsd. They seem to keep changing how they handle commands (kismet has several workarounds to try to handle different issues with gpsd).
> >
> > I don't know if they've fixed the packet parsing problem if multiple commands arrive in the same tcp packet, kismet introduces artifical delays to try to work around that.
> >
> > -m
> I'm just trying to find a version I can download and install
> What is the recomended version of gpsd to go with Kismet
> I tried 2.37 the newest and that fails as well
> I am looking for one to install but I dont know much about compiling from source so it is hard.
> *end of rant*
>
>
> What gpsd version will work
> Where can I get it? - (.deb packages are that best)

UPDATE
I just tried gpsd 2.33 and the same error happened It dectects a GPS but returns 0 when lock=true when lock=false it does not dectect a GPS
GPSd runs fine and reports all ok
The GPS is a "Meridan color" but I really dont want to buy a new one
is a post version of gpsd (one that has the right commands) worked into the newcore dev? one that is part of Kismet itself?
Thanks


Reply to this message