Kismet Wireless

Kismet Forums

 

Posted by:RNewman
Subject:Driver access difference between devl and newcore
Date:09:31:23 30/09/2008

> > > Okay, I think I've figured this out. Very strange to say the least. In all my testing and configuration I've been setting gps=false since I don't have a gps device. This morning I left the value as true and started up the new-core server. Guess what, it works! Now at least I have something to work from. Since I haven't looked at that part of your code so I'm not sure what is going on, but I'll take a look.
> >
> > That's very weird. I'll take a look.
>
> OK, two things:
>
> 1) I've rolled all the new source definition and privsep changes, see the devel blog. This changes how sources and drone sources are defined (for the better, I think)
>
> 2) I found and fixed the gps=false bug, I think.
>
> If you don't want to use the all-new code yet, you can make the following change in gps_wrapper.h... in the GPSNull class, change:
>
> virtual unsigned int MergeSet(unsigned int in_max_fd, fd_set *out_rset,
> fd_set *out_wset) {
> return 0;
> }
>
> to
>
> return in_max_fd;
>
> This should solve the gps issue killing things.
>
> I'd appreciate testing of the new source handling code, of course, too.
>
> -m

I've pulled the latest SVN and I'm having a problem getting my source to be recognized. I've tried ncsource=wlan0,interface=wlan0,type=ath5k which produces the following error message:

wlscanner@WLScanner02:~$ sudo kismet-newcore-new/kismet_server -f /etc/kismet/kismet.conf
ERROR: NOT spawning suid-root IPC capture control, because we are ALREADY
running as root. This is not the preferred method of running Kismet
because it prevents certain security features from operating.
INFO: Reading from config file /etc/kismet/kismet.conf
INFO: Setting drone connection buffer to 65535 bytes
INFO: Created alert tracker...
INFO: Kismet will attempt to hop channels at 5 channels per second unless
overridden by source-specific options
INFO: No specific sources named on the command line, sources will be read from
kismet.conf
ERROR: Failed to find a type for auto-type source 'wlan0,interface=wlan0,type=at
h5k', you will have to tell Kismet what it is by adding a type=[card
type] to the ncsource config
FATAL: Failed to add source 'wlan0,interface=wlan0,type=ath5k', check your
syntax and remember Kismet recently changed how it handles source
definitions!
Shutting down log files...
INFO: Shutting down plugins...

*** KISMET IS FLUSHING BUFFERS AND SHUTTING DOWN ***

It also requires that I code a channellist in the configuration file. I've read the development blog as well as the notes in the kismet.conf file on the new ncsource configuration, but at the moment all my attempts to configure it are failing with errors saying I have to code the type=[card] parm which I have.

Hope that's enough info to go on. I'll keep on trying.

-Richard


Reply to this message