Kismet Wireless

Kismet Forums


Posted by:xxzpxx
Subject:can NOT run kismet
Date:15:57:22 21/09/2008

ok people...PLEASE HELP

This is one last desperate attempt to get kismet working. for all of those who are not interested in my story and my steps just go to problem three, but for those who do read it please check are my steps correct.

I have been trying to install and run kismet for the past 5 days! I have left 10 gigs of HD, a lot of my time and a peace of my sanity with kismet!

let me fill you in from the start: i want to watch stream TV of my homeland (Bosnia, i now live in Seattle) but it keeps buffering and interrupting the program. So I decide to bridge my wire connection with a wireless connection. All the wireless connection i can see on my wireless adapter are password protected. So i see that kismet can help me get those pswds.
First problem i am using OS WINDOWS, always have been. I have tried everything to bypass that problem. I finally realised that Windows can't run Kismet. So i download linux UBUNTU, dual it with Windows and do all that stuff.
Second problem: This was the first time I have ever tried to install something on UBUNTU (i have used it before but just basic crap). i had no idea what to do. I thought it would be as simple as in Windows, just a double-click and it's there, but it was not. I guess to use UBUNTU one has to be a programmer. By the way, the documentation on this site is very hard to understand. I have read about a 100 sites describing how to install kismet, and finally decided to install with Synaptic. I guess it installed it...

****Third problem: The kismet.conf and replacing source. I should say now that i have bought my wireless card 3 years ago, and forgot the name and everything of it. So i go to System>Administration>Hardware Drivers and i see that i have Atheros Hardware access layer (HOV), and i look that up in kismet documentation 12. and see that the "code" for that is ether ath5k, ath5k_a or ath5k_ag, and after iwconfig find out that my "whatever" is eth0. I typed that info in kismet.conf. And now this is what i get when i type sudo kismet in terminal:

hana@hana-desktop:~$ sudo kismet
Launching kismet_server: //usr/bin/kismet_server
Suid priv-dropping disabled. This may not be secure.
No specific sources given to be enabled, all will be enabled.
Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
Enabling channel hopping.
Enabling channel splitting.
Source 0 (wifi): Enabling monitor mode for ath5k_ag source interface eth0 channel 6...
FATAL: mode get ioctl failed 95:Operation not supported

I have searched everywhere for this fatality and can't find IT, nothing relevant!

If anyone has any ideas please reply.

Reply to this message