Kismet Wireless

Kismet Forums

 

Posted by:RNewman
Subject:Driver access difference between devl and newcore
Date:07:26:07 17/09/2008

> > > I've been able to isolate where the problem, but not what is the cause. From my gdb experience I kept see the Packetsourcetracker::Poll just spinning and falling through the Sweep. desc kept showing a positive value, meaning that FD_ISSET kept returning 0. I commented it out in the Poll function and new-core server started to collect packets and record networks. Unfortunately while the client connected to the server, nothing was displayed in the UI screen.
> > >
> > > It appears that something has changed with the SELECT/FD_SET/FD_ISSET in the later kernels. I'll let you know if I find it.
> >
> > I'm running the latest released kernel for this test. Nothing has changed with select behavior - nearly every program on the system would fail if it had.
> >
> > It sounds, actually, like you may have an old libpcap which isn't handling things properly. Make sure you have the latest.
> >
> > -m
> And the light bulb may have just gone off. I'll pull the latest libpcap and let you know the results. I dug deeper in the code yesterday and realized that if the select/pd_isset were not functioning then lots of stuff would stop working.
>
> Thanks for being so patient with me.
> -Richard

Well I removed the libpcap-dev and libpcap0.8 packages from my server. Downloaded both tcpdump and libpcap0.9.8 sources, compiled and installed both.
Recompiled kismet. And, still the same, no luck. Very frustrating. I'm sure there is something missing from my system, but I can't find it.

I ran a tcpdump and had it write out a raw packet file. I used pcapfile as the source and re-ran new-core server. Nothing. I ran the file through the devl branch and it works.

So apparently I'm missing something newly required by new-core that was either built in or not needed in the older branch.

I'll keep digging.
-Richard


Reply to this message