Kismet Wireless

Kismet Forums


Posted by:RNewman
Subject:Driver access difference between devl and newcore
Date:10:28:14 15/09/2008

> >
> > Started the drone and tried to connect from the server. Nothing. Well okay, I fiddle with the config, nothing. Questions answered here indicate that my config is correct. Okay, reconfig and run the server again. Nothing. Well it worked before. Well that started the trials and tribulations of different wireless driver and OS's. Nothing. Okay, what does the older devl branch do. It works. That's strange. Restart newcore, nothing.
> >
> > Okay, so my question here is, can anything in the drone of newcore fiddle with wireless cards? As now, neither D-Link card or my USB wireless device work with new-core. But they all work without a problem in the devl branch.
> Of course the newcore drone can fiddle with the devices, it has to configure them in monitor mode.
> I still cannot recreate this problem. I even spent an hour getting running on my system (for some weak definition of running) to make SURE there were no bugs in the newcore packet capture code that would reject mac80211 based drivers and ath5k in particular.
> I can run kismet-newcore with the ath5k driver fine. I can also run kismet-newcore drones fine with ath5k. It also works fine across servers:
> INFO: Kismet drone client connected to remote server "Kismet-Drone" using
> protocol version 1
> INFO: Imported capture source 'ath5k,foo,wlan1' UUID 00008b12-8102-11dd-933d-001
> 56d66058c from remote drone
> INFO: Detected new managed network "ethersphere-wpa2", BSSID 00:0B:86:F6:67:C0,
> encryption yes, channel 1, 54.00 mbit
> so whatever is going on is local to your system, either your configs or ubuntu screwed up the ath5k drivers completely.
> Sorry,
> -m

Hi Mike,
I've been able to isolate where the problem, but not what is the cause. From my gdb experience I kept see the Packetsourcetracker::Poll just spinning and falling through the Sweep. desc kept showing a positive value, meaning that FD_ISSET kept returning 0. I commented it out in the Poll function and new-core server started to collect packets and record networks. Unfortunately while the client connected to the server, nothing was displayed in the UI screen.

It appears that something has changed with the SELECT/FD_SET/FD_ISSET in the later kernels. I'll let you know if I find it.


Reply to this message