Kismet Wireless

Kismet Forums

 

Posted by:RNewman
Subject:Driver access difference between devl and newcore
Date:09:21:42 12/09/2008

> > Hi,
> > I'm still hitting walls trying to figure out why the devl code works but newcore doesn't. It appears that there is some difference in the way newcore accesses the wlan device driver in newcore as opposed to devl.
> >
> > I would be happy to dig into the code and figure this out but I don't have a clue where to start.
> >
> > Any help would be greatly appreciated.
>
> They're almost completely different.
>
> pcapsource.cc and packetsource_pcap.cc, but beware, the newcore packet source handling is about to get replaced w/ a much simpler method.
>
> -m
Hi,
Thanks for the reply and heads up. After spending several hours looking through the code, yes indeed they are different 8)

Hopefully I'll get some additional time the run new-core through gdb to see what is happening during the interface setup.

A little past history may help shed some light.
For the most part the systems I'm testing on are Dell Optiplex GX520's. I have two D-Link WDA-1320, and a ZyXel USB. The D-Link's have the Atheros chipset and the ZyXel has a ZD1211 chip.

My OS is Ubuntu Server v8.04.1, and a variety of different wireless drivers.

The initial system had the latest ATH5K drivers from the MadWifi site.
Here I had the latest CVS copy of New-Core compiled and working on both Dell's w/D-Link cards. Traffic was collected and reported non-stop for a few days.

Now, since I wanted to run in the remote drone configuration I setup and configured one system as a drone.

Started the drone and tried to connect from the server. Nothing. Well okay, I fiddle with the config, nothing. Questions answered here indicate that my config is correct. Okay, reconfig and run the server again. Nothing. Well it worked before. Well that started the trials and tribulations of different wireless driver and OS's. Nothing. Okay, what does the older devl branch do. It works. That's strange. Restart newcore, nothing.

Okay, so my question here is, can anything in the drone of newcore fiddle with wireless cards? As now, neither D-Link card or my USB wireless device work with new-core. But they all work without a problem in the devl branch.

I'll let you know how the debugging turns out and if I run across anything of note.

Thanks...
-Richard


Reply to this message