Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:IPW3945 and RHEL5
Date:08:26:11 29/08/2008

> I have kismet running on FC6 with and IPW2200 card ok. I'm now trying to get it running with RHEL5 with an IPW3945. I initially tried the RPM - that installed ok, but then said Kismet wasn't compiled with IPW3945 support after changing the config. So, I then tried the source. The first problem is that the unzip comes up with two or three errors when trying to copy the /tmp files to the target directory (I am running as root, so permission should not be a problem). Looking at the errors, it implied that the problem was in a mv command and that the file already existed.

If you're running on a vfat or ntfs filesystem somewhere instead of ext (or other linux native) you're going to have no end of misery trying to copy/compile/build things. I'm guessing the target directory isn't a linux native filesystem.

> The main problem is that make then just throws up hundreds of errors, such as (from the first few lines):
> g++ -I../ -Wall -g -O2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -c kismet2xml.cc -o kismet2xml.o

That's an ancient tool for converting kismet binary logs to xml logs, you shouldn't need to (or really be trying to) compile it anymore. It's not compiled by default for a reason, it's really only still there incase someone has some truly ancient files (like, 6 years old) that they wanted to try to convert some day. Basically nothing in the extras/ dir is necessary for normal use.

-m


Reply to this message