Kismet Wireless

Kismet Forums

 

Posted by:RNewman
Subject:Newcore Drone / Server Configuration - again
Date:04:33:02 21/08/2008

> > I followed your example listed above, however once the server connects to the drone it immediately starts issuing:
> > ERROR: No frames from Kismet drone server at localhost:2502 in 20 seconds,
> > disconnecting
> > Over and over again.
> >
> > The drone, server and client are all on the same host.
> >
>
> that error means it's not connecting/negotiating.
>
> Look at loopback with tcpdump. Are you running any local input firewalls? Are you sure you're launching the newcore drone server and not the stable one from somewhere else in your path?
>
> -m
Still no luck. I just recompiled the latest svn and copy to my server.
Here is the output from a tcpdump on the loopback.

wlscanner@WLScanner1:~$ sudo tcpdump -i lo -vv
tcpdump: listening on lo, link-type EN10MB (Ethernet), capture size 96 bytes
03:00:28.058523 IP (tos 0x0, ttl 64, id 21611, offset 0, flags [DF], proto TCP (6), length 60) localhost.47649 > localhost.2502: S, cksum 0x624a (correct), 3197288296:3197288296(0) win 32792 <mss 16396,sackOK,timestamp 6155011 0,nop,wscale 6>
03:00:28.058800 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto TCP (6), length 60) localhost.2502 > localhost.47649: S, cksum 0xf245 (correct), 3199518197:3199518197(0) ack 3197288297 win 32768 <mss 16396,sackOK,timestamp 6155011 6155011,nop,wscale 6>
03:00:28.058847 IP (tos 0x0, ttl 64, id 21612, offset 0, flags [DF], proto TCP (6), length 52) localhost.47649 > localhost.2502: ., cksum 0xd968 (correct), 1:1(0) ack 1 win 513 <nop,nop,timestamp 6155011 6155011>
03:00:28.059448 IP (tos 0x0, ttl 64, id 4651, offset 0, flags [DF], proto TCP (6), length 60) localhost.48441 > localhost.gpsd: S, cksum 0x236e (correct), 3201431855:3201431855(0) win 32792 <mss 16396,sackOK,timestamp 6155012 0,nop,wscale 6>
03:00:28.059462 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto TCP (6), length 40) localhost.gpsd > localhost.48441: R, cksum 0x310f (correct), 0:0(0) ack 3201431856 win 0
03:00:31.099396 IP (tos 0x0, ttl 64, id 21613, offset 0, flags [DF], proto TCP (6), length 52) localhost.47649 > localhost.2502: F, cksum 0xd836 (correct), 1:1(0) ack 1 win 513 <nop,nop,timestamp 6155316 6155011>
03:00:31.109831 IP (tos 0x0, ttl 64, id 12021, offset 0, flags [DF], proto TCP (6), length 52) localhost.2502 > localhost.47649: ., cksum 0xd705 (correct), 1:1(0) ack 2 win 512 <nop,nop,timestamp 6155317 6155316>

---------

Also there are no firewalls, iptables -L shows no policies loaded. From the tcpdump, it looks as if the drone has not completely initialized.

I'm up for any suggestions. Once the tropical storm has ended in FL I'll try a different server distro. Any suggestions?

Thanks so much...Richard


Reply to this message