Kismet Wireless

Kismet Forums

 

Posted by:RNewman
Subject:Newcore Drone / Server Configuration - again
Date:13:18:42 20/08/2008

> > Okay, I'm at it again. I've got the latest newcore build 2423 from svn compiled with pcap, etc. It is currently running in the stand alone client/server configuration just fine. I've got three systems, one ubuntu 8.04 desktop one ubuntu 8.04 server and one ubuntu 8.10 server. My wireless cards are one zyxel usb and two d-link atheros cards. Again all work just fine in the client/server configuration.
> >
> > I would like to run all these (and more) in the drone configuration, however no matter what I try, I can not get a drone to collection information. I have even created a tcpdump/pcap file and fed that into the drone. Again, it just sits there without any indication that it is processing packets.
>
> The drone will have no output - it doesn't decode packets, only captures them.
>
> dragorn@drd1813 ~/src/kismet-newcore $ sudo ./kismet_drone -c madwifi_ag,wifi0,foo
> INFO: Reading from config file /usr/local/etc/kismet_drone.conf
> INFO: Setting drone connection buffer to 65535 bytes
> ...
> INFO: Madwifi source foo: Found monitor-mode VAP wifi0::kis0. We'll use that
> instead of making a new one.
> INFO: Source 0 (foo): Opening madwifi_ag source interface wifi0...
> INFO: Source 0 (foo): Opened source. UUID: 0000e4d8-6edd-11dd-b4e3-4c050125df01
> INFO: Created Kismet drone TCP server on port 2502
> INFO: Dropped privs to dragorn (1000) gid 1000
> ...
> INFO: Kismet drone starting to gather packets
>
>
> dragorn@drd1813 ~/src/kismet-newcore $ ./kismet_server -n -c drone,tcp://localhost:2502,foo
> INFO: Reading from config file /usr/local/etc/kismet.conf
> ...
> INFO: Setting drone connection buffer to 65535 bytes
> INFO: Created alert tracker...
> INFO: Channel hopping enabled in config file
> INFO: Channel splitting enabled in config file
> INFO: Created Kismet UI TCP server on port 2501
> INFO: Created Kismet drone TCP server on port 3501
> INFO: Dropped privs to kismet (1000) gid 1000
> ...
> INFO: Drone source 'foo' will automatically reconnect if the connection is lost.
> INFO: Source 0 (foo): Enabling monitor mode for drone source interface tcp://loc
> alhost:2502 channel 0...
> INFO: Source 0 (foo): Opening drone source interface tcp://localhost:2502...
> INFO: TcpClient connected to localhost:2502
> INFO: Source 0 (foo): Opened source. UUID: 0000d44c-6edd-11dd-a802-5c03110fab06
> INFO: Inserting basic packet dissectors...
> ...
> INFO: Registering dumpfiles...
> INFO: Pcap log in PPI format
> ...
> INFO: Kismet starting to gather packets
> INFO: Kismet drone client connected to remote server "Kismet-Drone" using
> protocol version 1
> INFO: Imported capture source 'madwifi_ag,foo,kis0' UUID 0000e4d8-6edd-11dd-b4e3
> -4c050125df01 from remote drone
> INFO: Detected new managed network "sw-ad-access5", BSSID 00:0B:86:44:19:C4,
> encryption no, channel 11, 54.00 mbit
>
> -m

Well,
I followed your example listed above, however once the server connects to the drone it immediately starts issuing:
ERROR: No frames from Kismet drone server at localhost:2502 in 20 seconds,
disconnecting
Over and over again.

The drone, server and client are all on the same host.

I tried with my atheros card, my pcap file and at zyxel usb. All the results are the same. I also tried using the madwifi source rather than the ath5k source with the same result.

What OS is your system running? I don't mind switching.
Are there any other setting that would give debug messages to help isolate this problem?

Thanks...Richard


Reply to this message