Kismet Wireless

Kismet Forums

 

Posted by:Habakster
Subject:newcore: Failed to open pcap dump file
Date:10:07:05 12/08/2008

> [edit] Run kismet_server in one terminal and the newcore client in another and see what's going on - I don't suggest using the kismet loader script right now, and I'm about to change how all that gets loaded to make it easier in the future to configure/manage. Maybe something funny is going on w/ what kismet gets loaded.

I tried running the server and client separately - but still no luck. As far as I can see there are no errors but I just don't receive any packets. My configuration is as follows:

demo@demo-laptop:~/tmp$ dpkg -s libpcap0.8-dev | grep Version
Version: 0.9.8-2
...
demo@demo-laptop:~/tmp$ modinfo ath_pci | grep version
version: 0.9.4

demo@demo-laptop:~/tmp$ sudo modprobe -r ath_pci ath_rate_sample ath_hal wlan_scan_sta wlan
demo@demo-laptop:~/tmp$ sudo modprobe -v ath_pci autocreate=none
insmod /lib/modules/2.6.24-19-generic/volatile/ath_hal.ko
insmod /lib/modules/2.6.24-19-generic/madwifi/wlan.ko
insmod /lib/modules/2.6.24-19-generic/madwifi/ath_pci.ko autocreate=none

demo@demo-laptop:~/kismet/log$ sudo /opt/kismet-newcore/bin/kismet_server
INFO: Reading from config file /opt/kismet-newcore/etc/kismet.conf
INFO: No 'dronelisten' config line and no command line drone-listen argument
given, Kismet drone server will not be enabled.
INFO: Created alert tracker...
INFO: No specific sources named, all sources defined in kismet.conf will be
enabled.
INFO: Channel hopping enabled in config file
INFO: Channel splitting enabled in config file
INFO: Source 0 (atheros): Enabling monitor mode for madwifi_ag source interface
wifi0 channel 6...
INFO: Madwifi source atheros created monitor-mode VAP wifi0::kis0.
INFO: Interface 'kis0' is already marked as being in monitor mode, leaving it
as it is.
INFO: Source 0 (atheros): Opening madwifi_ag source interface wifi0...
INFO: Source 0 (atheros): Opened source. UUID:
0000f8b2-688d-11dd-8453-0016cfb98928
INFO: Created Kismet UI TCP server on port 2501
INFO: Kismet drone framework disabled, drone will not be activated.
INFO: Dropped privs to demo (1000) gid 1000
ERROR: Failed to open primary plugin directory (/opt/kismet-newcore/lib/kismet/)
: No such file or directory
ERROR: Failed to open user plugin directory (/home/demo/.kismet//plugins/): No
such file or directory
INFO: Inserting basic packet dissectors...
INFO: Allowing Kismet frontends to view WEP keys
INFO: Starting GPS components...
INFO: GPS support disabled in kismet.conf
INFO: Creating network tracker...
INFO: Probe network tracking disabled by config file
ERROR: Netracker failed to read SSID cache file '/home/demo/.kismet/ssid_map':
No such file or directory
ERROR: Netracker failed to read IP cache file '/home/demo/.kismet/ip_map': No
such file or directory
INFO: Registering dumpfiles...
INFO: Pcap log in PPI format
INFO: Opened pcapdump log file 'Kismet-Aug-12-2008-9.pcapdump'
INFO: Pcap log saving all beacon frames
INFO: Pcap log saving PHY frame types
INFO: Pcap log saving corrupt frames
INFO: Opened netxml log file 'Kismet-Aug-12-2008-9.netxml'
INFO: Opened nettxt log file 'Kismet-Aug-12-2008-9.nettxt'
INFO: Opened gpsxml log file 'Kismet-Aug-12-2008-9.gpsxml'
INFO: Kismet starting to gather packets

demo@demo-laptop:~/kismet/log$ /opt/kismet-newcore/bin/kismet_client
--- No networks seen ---
INFO: Welcome ...
INFO: TcpClient connected to 127.0.0.1:2501
INFO: Established connection with Kismet server '127.0.0.1:2501'
... (nothing happens) ...

demo@demo-laptop:~/kismet/log$ dmesg | tail -n 20
[ 3283.071223] ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
[ 3283.104590] wlan: 0.9.4
[ 3283.111550] ath_pci: 0.9.4
[ 3283.111810] ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 21
[ 3283.111828] PCI: Setting latency timer of device 0000:03:00.0 to 64
[ 3284.260487] ath_rate_sample: 1.2 (0.9.4)
[ 3284.262052] wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[ 3284.262064] wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
[ 3284.262068] wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[ 3284.262078] wifi0: H/W encryption support: WEP AES AES_CCM TKIP
[ 3284.262082] wifi0: mac 10.3 phy 6.1 radio 10.2
[ 3284.262088] wifi0: Use hw queue 1 for WME_AC_BE traffic
[ 3284.262090] wifi0: Use hw queue 0 for WME_AC_BK traffic
[ 3284.262092] wifi0: Use hw queue 2 for WME_AC_VI traffic
[ 3284.262095] wifi0: Use hw queue 3 for WME_AC_VO traffic
[ 3284.262097] wifi0: Use hw queue 8 for CAB traffic
[ 3284.262099] wifi0: Use hw queue 9 for beacons
[ 3284.262103] wifi0: Atheros 5212: mem=0xedf00000, irq=21
[ 3286.289883] device kis0 entered promiscuous mode
[ 3286.289896] audit(1218559397.453:11): dev=kis0 prom=256 old_prom=0 auid=4294967295


excerpt from kismet.conf:
source=madwifi_ag,wifi0,atheros

Am I missing something? Any help is appreciated!
H.


Reply to this message