Kismet Wireless

Kismet Forums

 

Posted by:Habakster
Subject:newcore: Failed to open pcap dump file
Date:08:46:42 10/08/2008

I need kismet to dump per-packet signal strength information; a previous post suggested that this is available when kismet uses PPI headers which is supported (only?) by newcore. I pulled the current newcore from svn, compiled+installed successfully. After updating my kismet.conf I ran kismet (as root), and got the following error (linux, ubuntu hardy):

INFO: Registering dumpfiles...
INFO: Pcap log in PPI format
FATAL: Failed to open pcap dump file 'Kismet-Aug-10-2008-1.pcapdump':
Permission denied
Shutting down log files...

I reproduced the same error on a different machine (fedora core 6). On both machines I can successfully run Kismet-2007-10-R1 (I have not tried Kismet-2008-05-R1), but not newcore. The problem is the same with previous svn versions of newcore (e.g. I checked the code from 2 weeks ago). It looks like for me the problem is in dumpfile_pcap.cc of newcore, where it fails on the call to pcap_dump_open (line 374), and where pcap_geterr() - when I added it manually - returns: "... link-layer tyoe -1 isn't supported in savefiles". I'm using the pcaplib 0.9.8. Am I missing something?
Any help is greatly appreciated!

H.


Reply to this message