Kismet Wireless

Kismet Forums

 

Posted by:mtweed
Subject:fixed for the Atheros too!
Date:13:00:18 04/06/2008

> >
> > Fixed in SVN.
> >
> > For those who care:
> >
> > Some Intel macs report 802.3, and 802.11 + Radiotap.
> >
> > Some only report 802.3, 802.11, and 802.11+AVS.
> >
> > The DLT link setter only tried to set 802.11+Radiotap, which would fail, resulting in a EN10MB link.
> >
> > Now it'll set 802.11, 802.11AVS, and 802.11Rtap, in that order, and keep the "best" one of the set.
> >
> > KF just tested on a mac with a similar issue and it works w/ the latest svn checked in this morning.
> >
> > -m
>
> I am still having this problem...
>
> I have a macbook 2 ghz with intel core duo with 10.5.2. I am not sure what airport I have, but Kismet thinks it is an atheros.
> I checked out revision 2389 this afternoon from the devel. trunk and got the Following output:
> --
> INFO: en1 looks like an Atheros card running under Darwin.
> Source 0 (wifi): Enabling monitor mode for darwin source interface en1 channel 6...
> Source 0 (wifi): Opening darwin source interface en1...
> FATAL: pcap reported netlink type 1 (EN10MB) for en1. This probably means you're not in RFMON mode or your drivers are reporting a bad value. Make sure you have the correct drivers and that entering monitor mode succeeded.
> Done.
> --
> The stable release fails with:
> "FATAL: BIOCSETIF: wlt1: Device not configured", which the development version seem s to have fixed.

Fixed absolutely in kismet-2008-05-R1 stable!! :) thanks!


Reply to this message