Kismet Wireless

Kismet Forums

 

Posted by:x2dz
Subject:Can't get gpsmap on Freebsd /pcbsd/ 6.3-RELEASE-p1 -> library trouble
Date:03:14:27 30/03/2008

> > > hi everyone... I've been trying to get gpsmap to compile for the last 12 hours. Kind of crazy about now...
> >
> > > /usr/local/include/gmp.h
> >
> > >
> > > And third - a search for the ImageMagick libraries ->
> > >
> > > pcbsd# find / -name "*agick*"
> >
> > >
> > > As you can see from the configure output somehow it detects the Expat libraries... I should mention that I'm not really big in the whole *libraries* scheme so if anyone should try to help, please be precise and patient...
> > >
> > > Once again,
> > > Any help would be greatly appreciated!
> > >
> >
> > According to your config.log file and the configure output, you don't have the location of the gmp header files in your path for include files - thats why the configure script doesn't pick them up, as shown in your output from the configure step.
> >
> > You need the header files installed, and you need to tell the configure script where, if they are in a non standard location to the normal include files.
> > Fix that, and you should be able to compile gpsmap.
> >
> > Dutch
>
>
> First of all, thanks for the reply!
>
>
> Next, I have to again stress that I'm using FreeBSD, as oposed to Linux /as most of you are judging from the httpd-access.log/
>
> I'm currently googling around for the things you said since they make no sense to me and I don't really know what to do.
>
> If you have the time, could you write the approximate steps I need to take - it would save me a ton of work.
>
> Thanks again



After some research I concluded that the "header file" is actually the 'gmp.h' file. And so I did a search of where the expat.h file had copies /config reports expat OK/ and the only place there was an expat.h and no gmp.h was /usr/lib . So i copied gmp.h there and ran ./config again, but the result was the same...


Looking at config.log I keep seeing

configure:8792: checking gmp.h usability
configure:8809: gcc -c -g -O2 conftest.c >&5
conftest.c:102:17: gmp.h: No such file or directory
configure:8815: $? = 1
configure: failed program was:
| /* confdefs.h. */

What I want to know is - WHERE THE FUCK IS configure SEARCHING? Which is the goddamn directory in which there needs to be a gmp.h, but there isn't?

I think that if I can find that out I may be on the way to resolving this...

I should mention that I tried looking at line 8809 on configure, but the script seemed really screwed up to me and I couldn't understand which directory it searched in...

Help appreciated...


Reply to this message