Kismet Wireless

Kismet Forums

 

Posted by:roundqube
Subject:ath5k drivers for public safety
Date:12:17:03 17/02/2008

I had the ath_pci (madwifi 0.9.3) drivers working under Kismet but my Ubiquiti SR4C card would not show up in Kismet for channels 5,10,15 and 85,90,95 for the public safety spectrum. All channels between 20-80 worked fine when the AP was set to these channels, it would show up in Kismet.

One of the things with the ath_pci module was you could pass the countrycode=840 option to change the card to read only public safety (4.9Ghz) rather than the 5.8Ghz that it defaults to.

I then upgrade my kernel and used the ath5k drivers but it reads as a 5.8Ghz card again and adding the "options countrycode=840" line in my /etc/modprobe.d/options file, the module errors stating this is an invalid parameter. How do I set the country code in the new drivers so it will set the card to work on the public safety spectrum?

Sorry for the long post but I am really trying hard to get the SR4C to work under Kismet to read public safety spectrum during testing for my company deployment metro wifi to the City.

Thanks,
RoundQube


Reply to this message