Kismet Wireless

Kismet Forums

 

Posted by:Dutch
Subject:SUID changed but kismet doesn't recognize
Date:08:10:48 02/02/2008

> i did my configure and installation fine. I changed my config suid and when I run kismet it still tells me i haven't. I feel like I'm missing something very obvious.
>
> Here is my output:
>
> Launching kismet_server: /usr/local/bin/kismet_server
> FATAL: Could not find user 'your_user_here' for dropping priviledges. Make sure you have a valid user set for 'suiduser' in your config file. See the 'Installation & Security' and 'Configuration' sections of the README file for more information.
> Done.
>
> I know this is in the readme approximately 9 times. Yes, again, I changed the suid in the config file.
>
> Can anyone toss me a rope?
Kismet is reading another conf file than the one you edited.

You probably have edited the wrong kismet.conf file. Check that you don't have multiple versions around, and are editing the wrong one.

A typical error for debian users are to first install the deb package from the debian repositories, which places the kismet.conf file in /etc/kismet.

Then they figure out that the deb package is outdated, download the tarball or check out the latest dev version from svn, and forgets to configure the location for the conf files with the --sysconfdir statement. That means the selfcompiled binary will look for the kismet.conf in the default location of /usr/local/etc instead. The user, who didn't read the config.log, or kept an eye on the configure screenoutput, keeps editing the /etc/kismet/kismet.conf and then thinks something is borked with kismet, when actually it is their brains that are borked.

Either reconfigure with the proper sysconfdir, compile, and install again, or pass the kismet.conf file location to the binary with the -f option when starting kismet.

Dutch


Reply to this message