Kismet Wireless

Kismet Forums

 

Posted by:skan
Subject:my interfaces get destroyed
Date:13:57:19 22/01/2008

Hi

I'm using the latest madwifi drivers (for my Atheros card) and Kismet.

When I start up Linux I can use my wireless network perfectly,
And iwconfig shows the interfaces:
lo no wireless extensions.
wifi0 no wireless extensions.
ath0 IEEE 802.11g ESSID:"mine" Nickname:""
Mode:Managed
..... many data


When I run Kismet it does work properly and it creates its own interface in monitor mode, or it uses another one if that were already made (by me).
Tha problem is that when I quit Kismet it destroys my managed interface instead of the monitor one.
Then, I need to create a new one with
wlanconfig ath0 create wlandev wifi0 wlanmode managed nosbeacon

and a new problem arises, wlanconfig choose a random name for the interface (e.g ath11), I'm not able to force it to choose ath0.
This is a problem for me because the network manager needs to be configured again in order to connect with the new interface as the old one doesn't exist any more.


How can I get Kismet not to destroy my managed interface?
How can I get wlanconfig to create ath0 instead of athxx?

I've been looking on etc/network/interfaces but I can't solve the problem.
airmon-ng doesn't solve it either.
I'm using source=madwifing_g, wifi0, Atheros at kismet.conf but I've also tried with other options.


Reply to this message