Kismet Wireless

Kismet Forums

 

Posted by:pshootr
Subject:ipw2200 injection patch issue
Date:07:29:59 20/01/2008

> > Ok, awhile back I Installed the ipw2200 1.2.2 drivers, and appropriate firmware. I had kismet working. Tonight I reinstalled the 1.2.2 drivers after patching them with the ipw220 1.2.2-injection.patch. And now when start kismet I get this message below. Could this be because the source ID has changed.
> > -----------------------
> > ~$ sudo kismet
> > Server options: none
> > Client options: none
> > Starting server...
> > Waiting for server to start before starting UI...
> > Suid priv-dropping disabled. This may not be secure.
> > No specific sources given to be enabled, all will be enabled.
> > Enabling channel hopping.
> > Enabling channel splitting.
> > Source 0 (wifi): Enabling monitor mode for ipw2200 source interface eth1 channel 6...
> > FATAL: Failed to set monitor mode: Invalid argument. This usually means your drivers either do not support monitor mode, or use a different mechanism for getting to it. Make sure you have a version of your drivers that support monitor mode, and consult the troubleshooting section of the README.
> > [1] + Done(1) ${BIN}/kismet_server --silent ${server}

I repatched the drivers with another patch, and patched the ieee80211. Now Kismet can induce monitor modeagain :), but now I can't figure out how to set monitor mode manually. I tried "iwconfig eth1 mode monitor", that dosn't do it.... Any ideas?


Reply to this message