Kismet Wireless

Kismet Forums

 

Posted by:ArchangelUriel
Subject:make install [commoninstall] Error 1 (cannot stat `kismet': No such file or directory)
Date:01:47:25 21/11/2007

> > make -e commoninstall
> > make[1]: Entering directory `/home/despotak/Desktop/kismet-2007-10-R1'
> > mkdir -p /usr/local/etc
> > mkdir -p /usr/local/bin
> > install -o "root" -g "root" -m 755 kismet /usr/local/bin/kismet
> > install: cannot stat `kismet': No such file or directory
> > make[1]: *** [commoninstall] Error 1
> > make[1]: Leaving directory `/home/despotak/Desktop/kismet-2007-10-R1'
> > make: *** [install] Error 2
> >
> >
> > Plz some help. What maybe the problem?
>
> As someone (Antony Smith, to give credit) just sent me an email about, if you do 'make install' without doing 'make', you'll get this error because of a makefile bug. One could make the case you didn't follow the docs, to do 'make' and then 'make install', but I'll take the blame on this one :)
>
> Run a 'make' or 'make all' first before your make install.
>
> -m

I have done "make" before the "make install"... But It's OK now. I deleted the files and tried again. For reasons unknown to me it worked just as it sould be... Thank you any way... But now we now from where this error might come...


Reply to this message