Kismet Wireless

Kismet Forums

 

Posted by:samueldg
Subject:SPEC for Redhat 5 for SPECTOOLS (Please, include it in sources)
Date:21:59:23 12/10/2007

%global _version 2007-10-R1
%global _rpmversion 0.0.%(echo %_version | tr - .)


Summary: Spectrum-Tools is a set of utilities for using the Wi-Spy USB spectrum analyzer hardware from Metageek LLC.
Name: spectools
Version: %_rpmversion
Release: 2_ArcosCom
License: GPL
Group: Applications/Internet
URL: http://www.kismetwireless.net/spectools/
Source0: http://www.kismetwireless.net/code/%name-%_version.tar.gz
Packager: Samuel Díaz García <samueldg@arcoscom.com>
Vendor: ArcosCom Wireless, S.L.L., http://www.arcoscom.com
BuildRoot: %_tmppath/%name-%version-%release-root
BuildRequires: glibc-devel libusb-devel
BuildRequires: gtk+-devel gtk2-devel atk-devel
BuildRequires: pango-devel cairo-devel
BuildRequires: glib2-devel
BuildRequires: gcc make
# should be required by ImageMagick-devel but are missing in FC4
Requires: glibc
Requires: libusb-devel
Requires: gtk+ gtk2 atk
Requires: pango cairo
Requires: glib2 >= 2.14

#Obsoletes: wispy-tools

%description
Spectrum-Tools is a set of utilities for using the Wi-Spy USB spectrum analyzer hardware from Metageek LLC.
They include userspace drivers for the hardware (implemented via libusb), a graphing UI built on GTK/Cairo, network servers for remote devices, and simple utilities for developing additional tools.
%prep
%setup -q -n %name-%_version
%build
%configure
make clean
make all

%install
mkdir -p $RPM_BUILD_ROOT%_bindir
install -p -m755 spectool_raw spectool_net spectool_gtk $RPM_BUILD_ROOT%_bindir
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/
install -p -m644 99-wispy.rules $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/

%clean
%{__rm} -rf $RPM_BUILD_ROOT

%files
%_bindir/spectool*
%{_sysconfdir}/udev/rules.d/99-wispy.rules

%changelog
* Wed Oct 10 2007 Samuel Díaz García <samueldg@arcoscom.com> - 0.0.2007.10.R1-1_ArcosCom
- Update package for spectools 2007-10-R1

* Fri Sep 28 2007 Samuel Díaz García <samueldg@arcoscom.com> - 0.0.2006.09.R1-1_ArcosCom
- Initial package for wispy-tools 2006-09-R1


Reply to this message