Kismet Wireless

Kismet Forums

 

Posted by:Toranoko
Subject:(Yet another) Kismet on Windows Q.
Date:15:33:33 10/10/2007

> > I run Kismet from Windows XP. The server craps out with the infamous "/kismet_server.pid could not write ..." error. I have monkeyed around with the config file -- I know that it's reading the config because I get the expected error when I comment out the piddir variable. But nothing that I *do to* the piddir variable has any effect; i.e. if I change piddir to /tmp/ the error is still "/kismet_server.pid ...". The standard value, ./ , seems like it should work, but it does not -- nor does it appear to be integrated in the error message. The "Kismet for Windows Configuration Utility" seems to be working fine -- e.g. it finds my device, let's me edit the config files, and I get the exact same problems when executing manually from the command line instead of using the "apply and run" button.
>
> I'm not entirely sure what error you're referring to. Sounds like you're telling it a directory that doesn't exist or which has weird permissions on it though. Maybe someone more familiar with windows can aid (or maybe a previous post on the forums here has info)

I've seen other posts with errors like "I set the piddir to '/tmp/' and it now says '/tmp/kismet_server.pid, couldn't open for writing ...'", which was usually a permissions problem. (I'm using NTFS, but I have admin rights so it probably not permissions.) In my case, setting "piddir=/tmp/" does nothing at all; the error still says "/kismet_server.pid", implying an attempted write at the root directory (which should still work ...).

Setting it to a nonsensical value (say 'sdkchdhg') also does nothing at all (the error is stil "/kismet_server.pid ...", and not "sdkchdhg/kismet_server.pid ..."). The only reason I know that the config file is even being parsed is because commenting it out causes a different type of failure (the you must set piddir warning ...).

Is that more clear, or am I just confusing things more?

John


Reply to this message