Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Problem starting kismet
Date:21:16:43 06/10/2007

> Hello, when I run kismet after setting up it's config file I run into the following error:
>
> ...
> NOTICE: Created Madwifi-NG RFMON VAP kis0
> WARNING: wifi0 appears to be using Madwifi-NG. Some versions of the Madwifi-NG drivers have problems in monitor mode... etc
> FATAL: GetIFFlags: interface kis0: No such device
>
> Then terminates. I have destroyed my ath0 VAP before running kismet, but no matter what I do, it will not run past this error.
>
> Any ideas? Thanks in advanced, - Peter

Looks like it's either erroneously getting a success from the vap create ioctl, or something is rapidly tearing down the kismet vap before the next step - maybe something in udev is screwed up and renaming the interface immediately after it's created? When kismet exits, do you now have a monitor-mode vap named something else? What happens if you manually create a monitor mode vap named kis0?

-m


Reply to this message