Kismet Wireless

Kismet Forums

 

Posted by:qlenfg
Subject:Startup error
Date:05:30:00 26/09/2007

> Here is my start-up error I can't seem to get past:
>
> ------------------------------------------------
> alan@oldcompaq:~$ sudo kismet
> Server options: none
> Client options: none
> Starting server...
> Waiting for server to start before starting UI...
> Will drop privs to alan (1000) gid 1000
> No specific sources given to be enabled, all will be enabled.
> Enabling channel hopping.
> Enabling channel splitting.
> FATAL: Support for capture source type 'rt8180' was not built. Check the output from 'configure' for more information about why it might not have been compiled in.
> [1] + Done(1) ${BIN}/kismet_server --silent ${server}
> ------------------------------------------------
>
> Any suggestions? I'm using Ubuntu Feisty Fawn with the standard plug-and-play drivers that came with the distro (maybe that's the problem?). I'm using a Linksys WPC11 v.4 card, which uses the Realtek 8180L chipset, and this is also how it's recognized on the system. Here's the source info from my kismet.conf file:
>
> ------------------------------------------------
> source=rt8180,ethX,REALTEK
> ------------------------------------------------
>
> Please help! I'm very new to Linux so please be very easy on me. Thanks!

I think I got an answer. I was having the same grief when I tried to get my Zyxel card (also RT8185 chipset) working. Apparently in the Cassandra release of Linux Mint, the RT818x drivers are blacklisted in the modprobe.d. Since its based on Fiesty Fawn, its possible The Ubuntu release also has the drivers black listed.

Anywho, I un-blacklisted the card and got it recognized with iwconfig -- but Kismet barfed with the same message you were getting. I re-ran the complete Kismet install and it worked.

One thing I noticed is your source is ethX -- mine works as follows:

source=rt8180,wlan0,Xyxel_PCI

How does iwconfig list your card?

Hope this helps.


Reply to this message