Kismet Wireless

Kismet Forums


Posted by:dragorn
Subject:WiSpy woes on Linux
Date:17:54:58 22/08/2007

> Howdy - new to wispy - so don't discount the fact that I might be an idiot. Just be gentle with me ... please. :-)
> I picked up the WiSpy 2.4x and compiled wispy-tools-2006-09-R1.tar.gz. I insert the WiSpy USB device, and I see it:

That release can't drive the wispy24x. It predates the hardware existing by about 6 months.

> I tried downloading the latest SVN code (revision 2221), and tried compiling on both CentOS 4.4 and OpenSuSE 10.2 - but I can't get it to compile:

Update the svn copy to R2222 and it ought to work. The networking support is slightly clunky, and the auto-floor calculations still need to be fixed, but it'll work.

There will be a release of the new code with 24x support Real Soon Now, it was pending adding proper network support, which is now almost complete. Then expect another release in a while with revamped device handling and log file support.

Oh, and make sure to re-run ./configure after pulling the new code.


Reply to this message