Kismet Wireless

Kismet Forums

 

Posted by:moses
Subject:wispy-tools (SVN) on openSUSE 10.2
Date:20:03:42 07/08/2007

Hi,

The new wispy-tools looks really cool; I was playing with it and my new wispy 2.4x.

SuSE complained during the compilation:

gcc -I./ -g -O2 -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/libpng12 -I/opt/gnome/include/gtk-2.0 -I/opt/gnome/lib64/gtk-2.0/include -I/opt/gnome/include/atk-1.0 -I/opt/gnome/include/pango-1.0 -I/opt/gnome/include/glib-2.0 -I/opt/gnome/lib64/glib-2.0/include -c wispy_hw_gen1.c -o wispy_hw_gen1.o
In file included from wispy_hw_gen1.c:43:
/usr/include/linux/usbdevice_fs.h:49: error: expected ‘:’, ‘,’, ‘;’, ‘}’ or ‘__attribute__’ before ‘*’ token
/usr/include/linux/usbdevice_fs.h:56: error: expected ‘:’, ‘,’, ‘;’, ‘}’ or ‘__attribute__’ before ‘*’ token
(etc.)

Solution was to #include <linux/compiler.h> before <linux/usbdevice_fs.h>:

Index: wispy_hw_24x.c
===================================================================
--- wispy_hw_24x.c (revision 2188)
+++ wispy_hw_24x.c (working copy)
@@ -32,6 +32,7 @@
#include <unistd.h>
#include <sys/stat.h>
#include <sys/ioctl.h>
+#include <linux/compiler.h>
#include <linux/usbdevice_fs.h>
#include <errno.h>
/*
Index: wispy_hw_gen1.c
===================================================================
--- wispy_hw_gen1.c (revision 2188)
+++ wispy_hw_gen1.c (working copy)
@@ -40,6 +40,7 @@
#include <unistd.h>
#include <sys/stat.h>
#include <sys/ioctl.h>
+#include <linux/compiler.h>
#include <linux/usbdevice_fs.h>
#include <errno.h>
/*



Mike


Reply to this message