Kismet Wireless

Kismet Forums

 

Posted by:cableguy
Subject:wlanng_avs source for linksys WPC11?
Date:00:24:34 16/07/2007

> > Hi group,
> >
> > I just recompiled a new 2.6.21.3 linux kernel for my Dell Inspiron 8200 including the following options to support my Linksys WPC11 v3 wireless card:
> >
> > # PCCARD (PCMCIA/CardBus) support
> > # CONFIG_PCMCIA_DEBUG is not set
> > CONFIG_PCMCIA=m
> > CONFIG_PCMCIA_LOAD_CIS=y
> > CONFIG_PCMCIA_IOCTL=y
> > CONFIG_CARDBUS=y
> > # PC-card Bridges
> > CONFIG_YENTA=m
> > CONFIG_YENTA_02=y
> > CONFIG_YENTA_RICOH=y
> > CONFIG_YENTA_TI=y
> > CONFIG_YENTA_ENE_TUNE=y
> > CONFIG_YENTA_TOSHIBA=y
> > CONFIG_PCMCIA_PROBE=y
> >
> > CONFIG_IEEE80211=m
> > CONFIG_IEEE80211_CRYPT_WEP=m
> > CONFIG_IEEE80211_SOFTMAC=m
> > CONFIG_IEEE80211_SOFTMAC_DEBUG=y
> > CONFIG_WIRELESS_EXT=y
> >
> > CONFIG_NET_RADIO=y
> > # CONFIG_NET_WIRELESS_RTNETLINK is not set
> > # CONFIG_ARLAN is not set
> > # CONFIG_WAVELAN is not set
> > # CONFIG PCMCIA_WAVELAN is not set
> > # CONFIG_PCMCIA_NETWAVE is not set
> > # CONFIG_HERMES is not set
> > # CONFIG_PCI_HERMES is not set
> > # CONFIG_PCMCIA_HERMES is not set
> > CONFIG_NET_WIRELESS=y
> > CONFIG_NET_PCMCIA=y
> >
> > I used the 2.6 kernel pcmcia option because the pcmcia-cs package say to do so. I compiled and installed linux-wlan-ng-0.2.8.
> >
> > # lsmod
> > Module Size Used by
> > prism2_cs 70784 1
> > p80211 29068 1 prism2_cs
> > pcmcia 36144 5 prism2_cs
> > yenta_socket 25484 6
> > pcmcia_core 37644 4 prism2_cs,pcmcia,yenta_socket,rsrc_nonstatic
> > rsrc_nonstatic 12544 1 yenta_socket
> >
> > I *DO* have green power and link lights on the card when I plug it in.
> >
> > I'm still using Kismet 2006.04.R1 because the latest version did not build with my 2.6.21.3 kernel.
> >
> > My source line from my kismet.conf file:
> >
> > suiduser=kismet
> > source=wlanng_avs,wlan0,prism
> >
> > Now, if I execute kismet as the kismet user, I get the following:
> >
> > # kismet
> > Server options: none
> > Client options: nont
> > Starting server...
> > Waiting for the server to start before starting UI...
> > Will drop privs to kismet (502) gid 502
> > FATAL: Unable to set up pidfile /var/run/kismet_server.pid, unlink() failed: Permission denied
> >
> > If I execute as root:
> >
> > Server options: none
> > Client options: nont
> > Starting server...
> > Waiting for the server to start before starting UI...
> > Will drop privs to kismet (502) gid 502
> > No specific sources given to be enabled, all will be enabled.
> > Enabling channel hopping.
> > Enabling channel splitting.
> > Source 0 (prism): Enabling monitor mode for wlanng_avs source interface wlan0 channel 6...
> > Source 0 (prism): Opening wlanng_avs source interface wlan0...
> > FATAL: pcap reported netlink type 1 (EN10MB) for wlan0. This probably means you're not in RFMON mode or your drivers are reporting a bad value. Make sure you have the correct drivers and that entering monitor mode has succeeded.
> >
> > /var/log/messages shows kernel: linkstatus=CONNECTED when I plug in the card.
> >
> > # ifconfig -a
> >
> > wlan0 Link encap:Ethernet HWaddr 00:##:##:##:##:##
> > inet6 addr: xxxx::xxx:xxxx:xxxx:xxxx/64 Scope:Link
> > UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
> > RX packets:0 errors:0 dripped:0 overruns:0 frame:0
> > TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
> > collisions:0 txqueuelen:1000
> > RX bytes:0 (0.0 b) TX bytes:368 (368.0 b)
> > Interrupt:3 Base address:0xe100
> >
> > So, can anyone point out why kismet is not running? wrong drivers? wrong config? kernel version too new?
> >
> > What I need is to do wireless network monitoring and also to join back into a network once my work with kismet is done. Eventually I also intend to demonstrate WEP cracking if I can get this to work.
> >
> > Please advise.
> >
> > Thanks.












i am having ???????the same problem. any feedback on this?????????


Reply to this message