Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Trouble with latest spectool (Wi-Spy) make
Date:19:50:00 06/07/2007

> I ran the ./configure, and that all came back with no errors. I run Make and get:
>
> XXXLT055:/home/xxxx/wispy-tools# make
> gcc spectool_container.o wispy_hw_gen1.o wispy_hw_24x.o spectool_hw_net.o spectool_gtk_hw_registry.o spectool_gtk_widget.o spectool_gtk_planar.o spectool_gtk_spectral.o spectool_gtk_topo.o spectool_gtk.o -o spectool_gtk -lpthread -lusb -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lXext -lXinerama -lXi -lXrandr -lXcursor -lXfixes -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lXrender -lpng12 -lfreetype -lz -lfontconfig -lX11
> spectool_gtk_spectral.o(.text+0x222): In function `wispy_spectral_draw':
> /home/kltxb/wispy-tools/spectool_gtk_spectral.c:254: undefined reference to `gdk_cairo_set_source_pixmap'
> collect2: ld returned 1 exit status
> make: *** [spectool_gtk] Error 1

Your gdk/gtk is backdated too far for it to have cairo integration. You (currently) need this.

-m


Reply to this message