Kismet Wireless

Kismet Forums

 

Posted by:nightowl
Subject:kismet and error with latest madwifi-ng drivers
Date:23:54:25 25/06/2007

> Hello everyone!
>
> I am some kind of newbie with kismet, and i just tried to start it again after i installed the very latest madwifi-ng drivers for my atheros chipset.
> Before, with my former madwif drivers it was ok , i could launch kismet, but now i get the following error. I already changed "ath0" to "wifi0" in kismet.conf as told by the first error message, and that is all i did.I run Kubuntu dapper drake as an OS.
> Thanks for help.
>
> sudo kismet
> Server options: none
> Client options: none
> Starting server...
> Waiting for server to start before starting UI...
> Suid priv-dropping disabled. This may not be secure.
> No specific sources given to be enabled, all will be enabled.
> Enabling channel hopping.
> Enabling channel splitting.
> Source 0 (madwifi): Enabling monitor mode for madwifi_ag source interface wifi0 channel 6...
> WARNING: wifi0 appears to not accept the Madwifi-NG controls. Will attempt to configure it as a standard Madwifi-old interface. If you are using madwifi-ng, be sure to set the source interface to the wifiX control interface, NOT athX
> FATAL: channel get ioctl failed 22:Invalid argument
> [1] + Done(1) ${BIN}/kismet_server --silent ${server}



Ok, i just rebooted the box, killed first my ath0 interface (i don't know if it was necessary,was it?) fired up kismet, and it is there, working like a charm.


Reply to this message