Kismet Wireless

Kismet Forums

 

Posted by:andlog6
Subject:gpsmap doesn't recongnize fonts and doesnt draw legend
Date:23:50:17 13/05/2007

Hello here is my gpsmap output

gpsmap -S 3 -o /kismet/logs/wifimap.gif /kismet/logs/kismet2.gps -trek

Reading AP manufacturer data and defaults from /usr/local/etc/ap_manuf
Reading client manufacturer data and defaults from /usr/local/etc/client_manuf
NOTICE: Processing gps file '/kismet/logs/kismet2.gps'
NOTICE: Opened associated network xml file '/kismet/logs/kismet2.xml'
NOTICE: Caching GPS file /kismet/logs/kismet2.gps
Processing 1905 sample points.
Map image scale: 10000
Minimum Corner (lat/lon): **.676800 x -**.353722
Maximum Corner (lat/lon): **.696762 x -**.300667
Map center (lat/lon): **.686781 x -**.327194
Loading map into Imagemagick structures.
Map url: http://tiger.census.gov/cgi-bin/mapper/map.gif?lat=**.686781&lon=-**.327194&wid=0.001&ht=0.033333&iwd=1280&iht=1024&on=majroads&on=places&on=shorelin&on=streets&on=interstate&on=statehwy&on=ushwy&on=water&tlevel=-&tvar=-&tmeth=i
Fetching map...
--16:26:20-- http://tiger.census.gov/cgi-bin/mapper/map.gif?lat=**.686781&lon=-**.327194&wid=0.001&ht=0.033333&iwd=1280&iht=1024&on=majroads&on=places&on=shorelin&on=streets&on=interstate&on=statehwy&on=ushwy&on=water&tlevel=-&tvar=-&tmeth=i
=> `map_**.686781_-**.327194_10000_1280_1024.gif'
Resolving tiger.census.gov... 148.129.75.160
Connecting to tiger.census.gov|148.129.75.160|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [image/gif]

[ <=> ] 70,856 210.05K/s

16:26:21 (209.09 KB/s) - `map_**.686781_-**.327194_10000_1280_1024.gif' saved [70856]

Loading map into Imagemagick structures.
Converting map to greyscale.
Calculating network coordinates and statistics...
Processing 123 raw networks.
Assigning network colors...
Plotting 123 networks...
Drawing track coordinates, width: 3...
gpsmap: unable to open image `map_**.686781_-**.327194_10000_1280_1024.gif': No such file or directory.
Calculating and drawing network circles...
Drawing center dot, size 2...
Drawing legend...
stringheight.. unable to read font `courier' (null)
stringheight.. unable to read font `courier' (null)
stringheight.. unable to read font `courier' (null)
stringheight.. unable to read font `courier' (null)
stringheight.. unable to read font `courier' (null)
stringheight.. unable to read font `courier' (null)
stringwidth... unable to read font `courier' (null)
stringwidth... unable to read font `courier' (null)
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
gpsmap: unable to read font `courier'.
Unlinking downloaded map.

of course real coordinates are blacked out with **

so, after that i have map with networks plotted on it but no legend. Looks like it is "unable to read font" Any idea how to fix this? Maybe specify different font for gpsmap? I use backtrack 2.0 Final.

This migt be a bug who knows.

Thank you


Reply to this message