Kismet Wireless

Kismet Forums

 

Posted by:sonzo
Subject:FATAL: 'get_mode' does not return integer parameters.
Date:19:06:18 08/05/2007

Hello every body; I've big problem!!!

I will paste all my problems and I hope that someone can help me :P

# ifconfig ath0
ath0 Link encap:Ethernet HWaddr 00:16:CF:A1:62:B1
inet addr:192.168.0.4 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::216:cfff:fea1:62b1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2265 errors:0 dropped:0 overruns:0 frame:0
TX packets:2211 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2177528 (2.0 MiB) TX bytes:283154 (276.5 KiB)


# kismet
Server options: none
Client options: none
Starting server...
Waiting for server to start before starting UI...
Will drop privs to sonzo (1000) gid 100
No specific sources given to be enabled, all will be enabled.
Enabling channel hopping.
Enabling channel splitting.
Source 0 (madwifi_ag): Enabling monitor mode for madwifi_ag source interface ath0 channel 6...
WARNING: ath0 appears to not accept the Madwifi-NG controls. Will attempt to configure it as a standard Madwifi-old interface. If you are using madwifi-ng, be sure to set the source interface to the wifiX control interface, NOT athX
FATAL: 'get_mode' does not return integer parameters.

I've madwifi-0.9.3 sucessfully installed but i dont know why kismet doesn't run :(

These are my changes on /etc/kismet.conf

# User to setid to (should be your normal user)
suiduser=sonzo

# ...
source=madwifi_ag,ath0,madwifi_ag

Anyone can help me? Thank you so much!

Cheers,
/Sonzo


Reply to this message