Kismet Wireless

Kismet Forums

 

Posted by:rainman
Subject:Problems starting Kismet
Date:15:46:26 21/03/2007

Hi there.

I've read all the documentation, faq and the forum, and it got me this far (not far at all actually):

1)I get this error:
Creating and opening named pipe '/tmp/kismet_dump'. Kismet will now block
until another utility opens this pipe.
Starting UI...
FATAL: Could not connect to localhost:2501.
Kismet exited.
And as someone said in a previous message, I did add the line "127.0.0.1 user localhost.localdomain localhost" in /etc/hosts, and I still get this error.
What else shoud I do?

2)I'm using a Proxim Orinoco silver card (with Atheros chipset ->so I installed the latest madwifi driver).The system is FC6, with kernel-2.6.19-1.2911. Does anyone know why after inserting the card , after the command iwconfig I apear to have to interfaces:

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"" Nickname:"Rainman"
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:31 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-96 dBm Noise level=-96 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

And why after I start kismet, I'm beeing noticed that another interface, kis0 is create, on which monitor mode is enabled, despite the fact that I already have wifi0 and ath0 interfaces? Overall, I get this message:

WARNING: Found a non-master non-monitor VAP wifi0::ath0. Madwifi-ng has historically had problems with normal-mode VAPs combined with monitor-mode VAPs. You may need to remove them.
NOTICE: Created Madwifi-NG RFMON VAP kis0
WARNING: wifi0 appears to be using Madwifi-NG. Some versions of the Madwifi-NG drivers have problems in monitor mode, especially if non-monitor VAPs are active. If you experience problems, be sure to try the latest versions of Madwifi-NG and remove other VAPs
Source 0 (madwifi): Opening madwifi_g source interface kis0...

In doc it says that the source must be wifiX for Madwifi-NG, and athX for Madwifi. What mark the delimitation between Madwifi-NG and Madwifi? (I"ve read that the newer releases of Madwifi are also known as Madwifi-NG, but how much newer, since what version?)

3)Regarding ipw3945 driver, everywhere I read it''s saying that for monitor mode to work, you have to uncomment certain lines in the drivers' makefile, and then install it by hand. Well I did, and I still get the well-known error when I try to put it in monitor mode. Any idea why? (I installed by hand, modifying previously the makefile, only the ipw3945 driver; the rest of the components: the ieee80211 subsystem,ipw3945d,ipw3945-ucode and the the kernel sources I installed previously, automatically, with yum).

Any help on these isuess would be greatly appreciated (especially on the 1st one).

Thx


Reply to this message