Kismet Wireless

Kismet Forums

 

Posted by:pwjones99
Subject:gpsmap and tracking
Date:17:29:09 31/01/2007

> > I am having an issue getting kismet to actually create a track map. No matter what switches I use, I cannot get gpsmap to actually put a track on the generated map. The output does show that the track is getting generated, but never shows on any maps I produce. Am I missing something or is there a package I need to load for this to work.
> >
> > As far as the system, I am running a fresh install of FC6, running both madwifi and ipw2200 as my sources and I used the livna rpm for kismet and kismet-extras. I am thinking that there is a package needed to produce the track on the map.
> >
> > Any help will be appreciated.
>
> Some addition information from the configure script
> Configuration complete:
> Compiling for: linux-gnu (i686)
> C++ Library: stdc++
> Installing as group: root
> Man pages owned by: man
> Installing into: /usr/local
> Setuid capable: yes
> Terminal Control: ncurses
> Curses interface: yes
> Panels interface: yes
> Linux Netlink capture: yes
> Linux wireless : yes
> Linux wireless v.22+ : yes
> pcap capture: yes
> airpcap control: n/a (only Cygwin/Win32)
> WSP100 capture: no
> Viha capture: n/a (only Darwin)
> Radiotap headers: yes
> Using local dump code: yes
> Imagemagick support: yes (6.2.8)
> Expat Library: yes
> GMP Library: yes
> PThread Support: yes
> libz compression: yes
>
> It looks like I have everything I need loaded. The maps come out great looking except there is no track line. I am using the following to create the maps:
>
> gpsmap -S3 -s 6000 -n 1 -e -t -o map1.jpg Kismet-XXX.gps

Just in case anyone else might have this issue, I finally got it working, but I have no idea why it needs to be done this way.

I end up having to run the gpsmap command twice. once with all parameters including the -D to keep the map, and then again and the track mysteriously appears. But you must save the downloaded map

i run this exact command twice

gpsmap -S 2 -s 10 -D -t -e -n 1 -o filename.jpg Kismet_file.gps

The first time it runs, it makes a map with the center dots but no track. The second time it runs, the track appears. I would assume because the first time run, I get an error that says:
gpsmap: unable to open image 'map_41.blahblahblah.gif': No such file or directory
but once I keep the map, all is well. This does the exact same thing if I run as myself or as root.


Reply to this message