Kismet Wireless

Kismet Forums

 

Posted by:tuctboh
Subject:FreeBSD 5.x / wi
Date:14:28:50 31/01/2007

> > Hi,
> >
> > I'm trying to run Kismet on FreeBSD 5.5 with a
> >
> > wi0: <NETGEAR MA401RA Wireless PC Card> at port 0xe000-0xe03f irq 11 function 0 config 1 on pccard0
> > wi0: using RF:PRISM2.5 MAC:ISL3873
> > wi0: Intersil Firmware: Primary (1.0.7), Station (1.3.6)
> > wi0: Ethernet address: 00:09:5b:3a:65:e0
> > wi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
> >
> > I try to run with the radiotap_bsd_b, but I know I miss packets constantly. I tried to sniff my home network, and after 1/2 an hour didn't get ANY "Cryptd"
> > packets. I also ran into that the machine became unbelievably sluggish, but I'm kewl with that if it works. :)
>
> Both those things sound like a driver problem -- userspace should never be able to make the kernel sluggish, but a bad interrupt locker in a driver certainly could.
>
> If theres a new FreeBSD kernel you can go to, or perhaps a patch that fixes that, I'd suggest trying it.
>
Went to 5.5-STABLE. It seems its sluggish only because the laptop has a slow processor :

CPU: Intel(R) Pentium(R) 4 Mobile CPU 1.70GHz (1694.51-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0xf24 Stepping = 4
Features=0x3febf9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,P
AT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM>

And I'm trying to scan many channels at once. So that could be it.

The problem still remains, though, that even though the packet count goes up and up, nothing in "Cryptd". It is a standard WEP AP with 40 bit encryption. Is there a better card type to tell it?

Thanks, Tuc


Reply to this message