Kismet Wireless

Kismet Forums

 

Posted by:tuctboh
Subject:FreeBSD 5.x / wi
Date:12:06:00 24/01/2007

> > Hi,
> >
> > I'm trying to run Kismet on FreeBSD 5.5 with a
> >
> > wi0: <NETGEAR MA401RA Wireless PC Card> at port 0xe000-0xe03f irq 11 function 0 config 1 on pccard0
> > wi0: using RF:PRISM2.5 MAC:ISL3873
> > wi0: Intersil Firmware: Primary (1.0.7), Station (1.3.6)
> > wi0: Ethernet address: 00:09:5b:3a:65:e0
> > wi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
> >
> > I try to run with the radiotap_bsd_b, but I know I miss packets constantly. I tried to sniff my home network, and after 1/2 an hour didn't get ANY "Cryptd"
> > packets. I also ran into that the machine became unbelievably sluggish, but I'm kewl with that if it works. :)
>
> Both those things sound like a driver problem -- userspace should never be able to make the kernel sluggish, but a bad interrupt locker in a driver certainly could.
>
> If theres a new FreeBSD kernel you can go to, or perhaps a patch that fixes that, I'd suggest trying it.
>
> -m

I've switched to the FreeBSD 5.5-STABLE as of last nite. I ran it again, and even started another machine in the house to download a 600M ISO. I still am not getting "Cryptd", and it still is sluggish (With a load average that gets into the 15 or 16 range at times.

Am I using the wrong way to address my card? I saw someone mention a radiotap_fbsd_b, but it didn't work for me. Is there a patch I'm unaware of?


Thanks, Tuc


Reply to this message