Kismet Wireless

Kismet Forums

 

Posted by:rayv5n
Subject:KISMET/GPSD/GooleEarth incorrect/inconsistent waypoint mapping help!
Date:06:22:24 10/01/2007


==versions==
gpsd 2.33
Kismet 2006.04.R1
Kismet earth(latest)

Just bought a Delorme LT-20 which works like a champ, or so it seems. I fired up gpsd /dev/ttyUSB0 then modify the kismet.conf file to include the default GPS configuration. I fired up kismet_server which work awesomely and watch intently as the logs began to splash across my inodes. Once I got the gps and xml files I stop kismet_server and applied kismet Earth php script liberal like this..

"php -f parse.php Kismet-blah-blah"

Which albeit some errors created the Kismet*.kml file. I then ran Google Earth and open the kml, oh joy! a was soon zooming down to my location gliding towards those AP marked waypoint with ease! There was just one problem, the waypoint representing my APs where 30 meters from where they should be. Instead of hovering over the building they were clear across the parking lot.

Ok so obviously I went wrong some where? I have to admit I did rush into this and probably missed some obscure readme on how to adjust/address this problem. I've googled my fingers to death and its plan that I don't know how to ask the right question. Could someone please point out the obvious to me please?

Some observations.

== GPSD strange-ness==
Occasionally GPSD stops talking to the LT-20 ( restart of the daemon fixes the problem)

===When starting kismet_server I get a lot of these messages==
Lost GPS signal.
Acquired GPS signal.
Lost GPS signal.
Acquired GPS signal.----> keep going until something interesting to log shows up then more of the same until we kill kismet_server <-----

===After running Kismet Earth===

php -f parse.php Kismet-blah-blah-blah
PHP Notice: Undefined offset: 1 in /var/log/kismet/parse.php on line 422
PHP Notice: Undefined offset: 1 in /var/log/kismet/parse.php on line 424
PHP Notice: Undefined offset: 1 in /var/log/kismet/parse.php on line 422
PHP Notice: Undefined offset: 1 in /var/log/kismet/parse.php on line 424
PHP Notice: Undefined offset: 1 in /var/log/kismet/parse.php on line 422
PHP Notice: Undefined offset: 1 in /var/log/kismet/parse.php on line 424
PHP Notice: Undefined index: wep-count in /var/log/kismet/parse.php on line 321
PHP Warning: Division by zero in /var/log/kismet/parse.php on line 321
PHP Notice: Undefined index: probe-count in /var/log/kismet/parse.php on line 324
PHP Notice: Undefined variable: lookatnet in /var/log/kismet/parse.php on line 328
PHP Notice: Undefined index: in /var/log/kismet/parse.php on line 328
PHP Notice: Undefined variable: lookatnet in /var/log/kismet/parse.php on line 328
PHP Notice: Undefined index: in /var/log/kismet/parse.php on line 328
PHP Notice: Undefined offset: -1 in /var/log/kismet/parse.php on line 352
PHP Notice: Undefined offset: -1 in /var/log/kismet/parse.php on line 353
PHP Notice: Undefined variable: kml_alt in /var/log/kismet/parse.php on line 355
PHP Notice: Undefined variable: kml_alt in /var/log/kismet/parse.php on line

<-----more of the same, probably from each line parsed ------->

PHP Notice: Undefined variable: line in /var/log/kismet/parse.php on line 377
PHP Notice: Undefined variable: kml in /var/log/kismet/parse.php on line 381
Kismet-*.kml saved.
PHP Notice: Undefined offset: 2 in /var/log/kismet/parse.php on line 391
Parsed in 0.01 seconds

I thought that this might be a problem with Kismet Earth but when I ran Netstumbler with the LT-20 then ran Netstumbler's export file through gpsvisualizer.com I got basically the same 30 meters or so strange-ness?

I haven't rules out interference or maybe something's wrong with the LT-20.
it could be that there's a nut loose on the keyboard.

cheers!


Reply to this message