Kismet Wireless

Kismet Forums

 

Posted by:sharpspark
Subject:channel get ioctl failed 22:Invalid argument
Date:15:58:41 29/12/2006

try doing this:

cardctl suspend
cardctl resume
sleep 3s
kismet

(on some systems replace suspend with "scheme cardsuspend" and resume with "scheme cardresume")

if you still have problems, create a new network connection.
Call it "kismet-wifi" or whatever you want.
Give it a static ip of 10.10.0.0 (no dhcp)
no dns,
leave ssid blank
then try doing this:
cardctl suspend
cardctl resume
cardctl scheme <name of scheme associated with the new net connection you created> &
sleep 3s
kismet

> First, thank you both for answering to my question.
> Like I wrote in my first message, I already tried ath0 instead of wifi0, but the only outcome was another Errormessage. (see below)
> The Wlan is the only connection of the computer, so there is no other net-connection which I could turn off.
>
>
> > Id also like to just mention for those still having trouble,
> >
> > 1. use athX like the previous poster said
> > 2. when actually scanning, turn off your 'net' connection because it just
> > intefers with the process.
> > 3. if all goes well you should be able to see networks and poll them for
> > information.
> >
> > > use interface athX and see what happends.
> > >
> > >
>
> > > > I installed kismet, edited the kismet.conf (put in my username and the
> > > > line "source=madwifi_g,wifi0,cisco") and inserted the card. After a few
> > > > moments I started kismet. What I got was the following:
> > > > FATAL: channel get ioctl failed 22:Invalid argument
>
> > > > I changed the line in the kismet.conf from wifi0 to ath0, but only to get
> > > > another errormessage: FATAL: 'get_mode' does not return integer
> > > > parameters.
> > > > So I changed it back to wifi0.


Reply to this message