Kismet Wireless

Kismet Forums


Posted by:yuwy
Subject:channel get ioctl failed 22:Invalid argument
Date:22:17:42 27/12/2006

Id also like to just mention for those still having trouble,

1. use athX like the previous poster said
2. when actually scanning, turn off your 'net' connection because it just
intefers with the process.
3. if all goes well you should be able to see networks and poll them for

> use interface athX and see what happends.
> > Hi,
> >
> > I use a pcipcmcia-wlan-card with a atheros-chip. I madwifi to use the card and its working fine.
> >
> > Now I want to use kismet.
> >
> > I installed kismet, edited the kismet.conf (put in my username and the line "source=madwifi_g,wifi0,cisco") and inserted the card. After a few moments I started kismet. What I got was the following:
> >
> > $ kismet
> > Server options: none
> > Client options: none
> > Starting server...
> > Waiting for server to start before starting UI...
> > Suid priv-dropping disabled. This may not be secure.
> > Enabling channel hopping.
> > Enabling channel splitting.
> > Source 0 (cisco): Enabling monitor mode for madwifi_g source interface wifi0 channel 6...
> > WARNING: wifi0 appears to not accept the Madwifi-NG controls. Will attempt to configure it as a standard Madwifi-old interface. If you are using madwifi-ng, be sure to set the source interface to the wifiX control interface, NOT athX
> > FATAL: channel get ioctl failed 22:Invalid argument
> >
> > And this is my problem. What does this messages mean and how can I avoid it? Google knows nothing about it.
> >
> > I changed the line in the kismet.conf from wifi0 to ath0, but only to get another errormessage: FATAL: 'get_mode' does not return integer parameters.
> > So I changed it back to wifi0.
> >
> > I tried "ifconfig ath0 down" before starting kismet (and the same with wifi0) but it didn't change anything.
> >
> > Could anybody help me or give me a hint where to look for more knowledge about this error?
> >
> >
> > Thanks,
> > Tom.

Reply to this message