Kismet Wireless

Kismet Forums


Posted by:sharpspark
Subject:problems getting kismet to work
Date:19:54:38 26/12/2006

why do u run kismet with sudo command if you are already root?

Also the line " source=none,none,addme " needs to be edited so that it matches your system setup. See documentation for the correct options.

And your chipset name "Belkin." I dont think is a name of an actual chipset.
I dont think.
Please make sure it's the actual name of the chipset because I also have a wifi card from belkin in my laptop but the chipset is cisco.

uncomment and Edit the line "#suiduser=boss" to be the user what kismet drops back to when it is running. This should be a normal non-root user.
For me, I have a user named "luser" so my line looks like this

When running kismet, I log in as luser and then do a su to root to run kismet from luser's directory then all log files created by kismet will have luser ownership.

> Hi all,
> I am running Dapper drake on a sony viao laptop model pcg-fxa53. Wifi card is a rt2500 chipset make by Belkin.
> I Insalled kismet using the synaptic package manager. I have read as much info as i can but i cant seem to get the program up and running. Perhaps I am making a stupid mistake in editing the kismet.conf
> after editing when i launch kismet i get the following error:
> root@boss-laptop:~# sudo kismet
> Server options: none
> Client options: none
> Starting server...
> Waiting for server to start before starting UI...
> Suid priv-dropping disabled. This may not be secure.
> No specific sources given to be enabled, all will be enabled.
> Enabling channel hopping.
> Enabling channel splitting.
> NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
> Source 0 (addme): Opening none source interface none...
> FATAL: Please configure at least one packet source. Kismet will not function if no packet sources are defined in kismet.conf or on the command line. Please read the README for more information about configuring Kismet.
> Kismet exiting.
> kismet conf file is set as follows:
> # Kismet config file
> # Most of the "static" configs have been moved to here -- the command line
> # config was getting way too crowded and cryptic. We want functionality,
> # not continually reading --help!
> # Version of Kismet config
> version=2005.06.R1
> # Name of server (Purely for organizational purposes)
> servername=Kismet
> # User to setid to (should be your normal user)
> #suiduser=boss
> # Sources are defined as:
> # source=rt2500,ethX,kismet[,initialchannel]
> # Source types and required drivers are listed in the README under the
> # CAPTURE SOURCES section.
> # The initial channel is optional, if hopping is not enabled it can be used
> # to set the channel the interface listens on.
> source=none,none,addme
> # Comma-separated list of sources to enable. This is only needed if you defined
> # multiple sources and only want to enable some of them. By default, all defined
> # sources are enabled.
> # For example:
> # enablesources=prismsource,ciscosource
> # Do we channelhop?
> channelhop=true
> # How many channels per second do we hop? (1-10)
> channelvelocity=5
> HELP what gives guys?

Reply to this message