Kismet Wireless

Kismet Forums

 

Posted by:RenderMan
Subject:Kismet Server and Drone
Date:22:08:51 22/09/2006

> Thanks for the info!
>
> but I've decided to upgrade the drone first, because I was running 2005.08.R1
> but after upgrading to 2006.04.R1 I'm getting following errors, any ideas?
> It's running on WRT54G v2 and I did set to monitoring mode with "wl monitor 1"
> infact I run following commands before running drone.
> /sbin/ifconfig eth1 up
> /usr/sbin/wl ap 0
> /usr/sbin/wl disassoc
> /usr/sbin/wl passive 1
> /usr/sbin/wl promisc 1
> /usr/sbin/wl monitor 1
> /usr/sbin/wl channel 11
>
> here is error messages. and only I've changed is source=wrt54g,eth1,Kismet-Drone
> -----------------------------------------
> Using alternate config file: kismet_drone.conf
> Suid priv-dropping disabled. This may not be secure.
> No specific sources given to be enabled, all will be enabled.
> Disabling channel hopping.
> Source 0 (Kismet-Drone): Enabling monitor mode for wrt54g source interface eth1 channel 0...
> Source 0 (Kismet-Drone): Opening wrt54g source interface eth1...
> FATAL: pcap reported netlink type 1 (EN10MB) for eth1. This probably means you're not in RFMON mode or your drivers are reporting a bad value. Make sure you have the correct drivers and that entering monitor mode succeeded.

Most likely you upgraded your OpenWRT version as well. Later versions have required the use of prism0 as the interface. http://www.renderlab.net/projects/wrt54g/openwrt.html


Reply to this message