Kismet Wireless

Kismet Forums

 

Posted by:samueldg
Subject:Problem running wispy_gtk under FC5
Date:20:21:45 27/08/2006

> > I forgot:
> > 1) Tried with distro kernel (and devel package).
> > 2) Tried with vanilla kernel 2.6.17.8 (and its sources).
>
>
> > > 2) With dhe USB wispy device connected into my laptop:
> > > $ wispy_gtk
> > > Unable to claim interface 0 -- are you root?
> > > Is something else using it (another program or the kernel HID)?
> > > USB capture child process exited!
>
> You're a victim of redhat not updating their headers properly.
>
> Try the svn pull of wispy-tools, that wispy-gtk internally defines the ioctl and tries it on any kernel, no matter what the headers say the kernel supports.
>
> This is a terrible hack to work around stupid, broken distributions.
>
> -m

Drag, thanks for your reply, and only 2 points more:
1) I say in a post that I tried a vanilla kernel (with a vanilla sources and it headers) with the same FC5 kernel results.
2) I think that all here are humans, and because sometimes we have some errors, we have not to pay allways for them.

And, again, thanks for your reply, I think I'm not the only user that uses FCx distributions.


Reply to this message